ACER Aspire 4520 tried to kill me…….(2)

I started to work on this unit since September 2007, tried to pump the Linux in. I have tried to install many distros; the result was failed and failed again. I considered this as a trigger for m to keep pushing myself harder in knowing about Linux. I didn’t want myself just as a Linux installer, i wanted more.

I have tried to install PCLOS2007, Vector, DreamLinux, OpenSuse, Skole, Slackware, Mandriva, IGOS to this laptop. But…like usual, it kept rejecting them. The last; i returned to edubuntu-7.04 again. I asked questions to edubuntu-users@lists.ubuntu.com about my problem. Any Linux that i installed on can not display a good graphic (graphic card problem), can not connect to the wireless and it’s mute (sound problem).

One of edubuntu users told me that i have to force this unit to run in save graphical mode by doing;

edit /etc/X11/xorg.conf, go to the Device stanza for your video card and change the driver to vesa, eg:

Section “Device”

Identifier “ATI Technologies, Inc. ATI Default Card”
Driver “vesa”
BusID “PCI:3:0:0”

EndSection

Then do sudo /etc/init.d/gdm restart

Actually, an alternative and possibly better way to do this is to run:

sudo dpkg-reconfigure xserver-xorg

You will be led through a series of menus. Take the default answer to all questions (there are quite a few), except where you are asked for the “X server driver”, when you should choose “vesa”. Once that’s done, try restarting the display manager

sudo /etc/init.d/gdm restart

yes, it worked….in safe graphic mode, but it didn’t satisfied me.

Two months passed by, slowly i found out the way to solve this problem. I used Ubuntu-7.10 ( Gutsy Gibbon ) and after searched for the answer at https://ubuntuforums.org and waiting from edubuntu-users answers. I can settle it down.

Here is the way out;

How to set the display ( nVIDIA 7000M )

go to Applications – Add/Remove
type nvidia and choose : nvidia binary X.org driver (‘new’ driver )
click on apply button and wait until the installation finished
go to system – Restricted Drivers Manager – enable the NVIDIA
open terminal
type sudo vi /etc/X11/xorg.conf
replace the resolution manually from “1024×768” to “1280×800”
reboot the computer

How to set the wireless ( Atheros – AR5007EG )

download the AR5007EG windriver
install ndiswrapper manually
open terminal; type sudo rmmod ath_pci ( remove the pci module )
type sudo vi /etc/modprobe.d/blacklist-common
insert : blacklist ath_pci ( to put ath_pci in blaklist mode )
save it and restart the computer
extract the windriver into one folder ( ex: documents )
go to System – Administration – Windows Wireless Drivers
install net521.inf
click configure button and set it up
open terminal; type sudo ndiswrapper -m ( to load ndis on restart )
reboot the computer

How to set the sound ( Realtek High Definition Audio a.k.a Realtek ALC268 )

install linux-backports-modules-2.6.22.14-generic
install linux-backports-modules-generic_2.6.22.14
open terminal; type sudo vi /etc/modprobe.d/alsa-base
insert : options snd-hda-intel model=acer
reboot the computer

By November 05, 2007, i finished my long journey to make ACER Aspire 4520 runs in Windows XP and Ubuntu Gutsy Gibbons, as an addition; this laptop was Vista design.. 😀

~E~

Advertisements

32 Comments

  1. Thanks a lot for ur help…got ubuntu running on my acer 4520.

  2. oh my friend thank you for this information. I wil try with my Acer 4520.

  3. I just cant setup the display on Acer 4520 (nVIDIA 7000M). Everytime I start Ubuntu it just stop its progress in the splash screen then afterwards initramfs appears. Its my first time to try Ubuntu. Could someone guide me? Thank you.

  4. did you encounter problem with network configuration. The eth device number is incrementing each time the laptop is rebooted.

  5. and fedora?
    i will try with my 4220
    thanks for yours tips.

  6. Hey.. thats a great collection of fixes for Ubutu 710 on Acer Aspire 4520. I was able to install it in the safe graphics ode and then got mot of the things working as mentioned in the post above only WiFi remaining, wil try that soon

    The only problem is with the Display. I a able to have it going into 1280×80 0 resolution with all 3D Effects working, but whenever I reboot, it keeps on going to 800×600 resolution and have to manually go and select the higher resolution. I am not able to find the entry in XORG.conf to mention the default resolution. Can somebody help me with this.???

  7. I have got the Solution for the Resolution problem… here it is

    1. Make sure the restricted driver is installed (in Synaptic search for nvidia-glx-new)
    2. Execute this command in a terminal:
    sudo dpkg-reconfigure -phigh xserver-xorg
    3. Open Restricted Drivers Manager and enable the nVidia driver.
    4. Reboot, and you should be good to go.

    Hope this helps..

  8. dear chadrich,
    -when you boot, select the first row, then press “e” to edit
    -add “all_generic_ide” at the end of the kernel line so become like this : kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=8770f1df-2ede-4ede-8d79-649ecdf50456 ro quiet splash all_generic_ide
    -then press “b” to boot

    next, after you get to desktop,

    -open terminal
    -sudo gedit /boot/grub/menu.lst
    -change the kernel line just like above ( add “all_generic_ide” after splash word )
    – sudo reboot

    i think : your ubuntu will run smothly now……

    regards;
    ~E~

  9. i am trying to connect my cell phone through bluetooth but the cell phone is not finding the computer.when i on the bluetooth in the laptop ,bluetooth icon is displayed but there is no connection with my cell phone

  10. bro please help me about the wireless….me newbie….when i run sudo rmmod ath_pci the following things appear
    ERROR: Module ath_pci does not exist in /proc/modules
    ERROR: Module ath_hal does not exist in /proc/modules
    ERROR: Module wlan does not exist in /proc/modules
    …what does it means??i already install ndiswrapper

  11. g3ndi7@g3ndi7-ubuntu:~$ sudo ndiswrapper -m
    [sudo] password for g3ndi7:
    module configuration already contains alias directive

    .
    .
    .
    module configuration already contains alias directive

    module configuration already contains alias directive
    ..when i type the command this error occurs…
    please help me….i desperate to use wireless…n then can i change from sudo vi /etc/modprobe.d/blacklist-common to sudo gedit /etc/modprobe.d/blacklist-common??…coz i dun know how to save in vi…i so so so noob…hehehehe

  12. bihan : i never used bluetooth….sorry for this
    gendit : it means your wireless was not atheros…could be broadcomm
    and also sudo vi can be replaced by sudo gedit or sudo nano
    maybe you can try madwifi or you can try this link : http://ubuntuforums.org/showthread.php?t=512828

  13. k…i try that..n one for the sound….can u show me in details how to get the linux backport??i really appreciate if u can…me newbie

  14. open terminal :==> sudo apt-get install linux-backports-modules

  15. yay sounds works….=)…thanks…ur my hero….hehehehe…but wireless still did’t find the solution….after i blacklist the ath_pci reboot….then after reboot i install the arteros driver but when the time to configure,can’t see the wireless…the same in the iwconfig…can u tell me what the problem?g3ndi7@g3ndi7-ubuntu:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

  16. acer_acpi-0.11.1…did’t i require to install this to??
    http://ubuntuforums.org/archive/index.php/t-546451.html

    I hav a Li1718 and I’ve got Wlan working.
    In Addition to the ndiwswrapper-module I downloaded acer_acpi
    (Please google for the Url I don’t have it available)
    compiled the module modprobe acer_acpi
    and then issued following command as root:
    echo 1 > /proc/acpi/acer/wireless
    The wlan-LED should turns on now and you should have a functioning and working wlan.
    By
    Noir8

    coz my wireless didn’t blinking at all…

  17. no you dont have to…….
    what is the output of this :==> sudo lshw -short -C network
    after that you should find the related driver

  18. this is the output….
    g3ndi7@g3ndi7-ubuntu:~$ sudo lshw -short -C network
    [sudo] password for g3ndi7:
    H/W path Device Class Description
    ==================================================
    /0/a eth0 network nVidia Corporation
    /0/e/0 network AR5006EG 802.11 b/g Wireless PCI Express

    i already take the driver from cd that acer provide and install it in ubuntu…but still the same….i try many driver also that are artheros but still didn’t show the wireless….hmmmm

  19. after many attempt,i try to reinstall back the ndiswrapper and using the artheros driver i downloads at their site…n after that,i cant see the wireless configuration…but it is normal that wireless oren button didn’t not blinking??i not try connect wireless coz only at office i use wireless…normal what?

  20. 1. hi, just wan to ask why my ubuntu 7.10 startup screen is in dark color. but it back to normal light color after i login.

    2. my sound will revert to the loudest for everytime i reboot my laptop. how to get rid on this even though I mute the sound before shutdown.

  21. ha when i try using the wireless in the office…it could detect the wireless network but when i try to connect, it cannot be connect….wa so cruel ar wireless nowdays…^_^

  22. yes…my orange indicator did not turn on but i can connect
    try not to use “any” in the ESSID….so you have to search the AP manually
    dont forget to open terminal and — sudo /etc/init.d/networking restart
    after you did anything to network manager…….
    heheh…that’s atheros……donno why !!

  23. i already done what u tell me to do…n when me try the sudo /etc/init.d/networking restart…it will tell dhcp offer is no n then lease ip is sleeping somethings like thatla…i think that the linksys broadband router in my office has a problem but when i use wireless in window…it work fine…haizz…truela…acer try to kill me 2la….

  24. hey in the restricted driver manager…you enable or disable the artheros HAL…i disable..but the wireless mode is missing again coz i reinstall the driver…make me lazy to reinstall back the ndiswrapper…adoiii

  25. n one more things….what version of ndiswrapper that u use??is the version and the driver install must compatible??

  26. g3ndi7@g3ndi7-ubuntu:~$ sudo /etc/init.d/networking restart
    [sudo] password for g3ndi7:
    * Reconfiguring network interfaces… There is already a pid file /var/run/dhclient.wlan0.pid with pid 7192
    killed old client process, removed PID file
    Internet Systems Consortium DHCP Client V3.0.5
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    Listening on LPF/wlan0/00:1f:3a:0c:47:20
    Sending on LPF/wlan0/00:1f:3a:0c:47:20
    Sending on Socket/fallback
    There is already a pid file /var/run/dhclient.wlan0.pid with pid 0
    Internet Systems Consortium DHCP Client V3.0.5
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    Listening on LPF/wlan0/00:1f:3a:0c:47:20
    Sending on LPF/wlan0/00:1f:3a:0c:47:20
    Sending on Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 1
    No DHCPOFFERS received.
    No working leases in persistent database – sleeping.

  27. helo there…i dun know what happen,but suddenly my wireless can be used…yay….thanks for ur help….i’m really appreciate it…

  28. thanks friend.

    information on this post helped a lot.

  29. I have been through a lot trying to get this computer up and running with this acer 4520 laptop. I have tried to do everything on my own up to this point. My sound still is not working and I have tried to find and install the backport you have said but I cannot find it in my add/remove programs or the web. Can you tell me where to get this so that I can get my sound. That is the last thing left. I had trouble installing the wireless for a while but i did not have the 5211 .cat file in with the inf file so i struggled lol. I am such a nub. If you can help me I would be appreciative. thank you for your time.

  30. Thank you, thank you, thank you. YEAH!!!!!!! It works now. I am happy everything works. Man I am really glad there are people out there like you. I had my wifi up and running for a couple days now but it took me 2 weeks to figure out I needed the .cat file along side of the inf file. then it started working all of a sudden. but it was this page that I had printed out from windows to figure it out in linux after downloading a ton of things to make sure I had the right things. It has been one big headache. I got it now thanks to you.

    Sicerely,
    Jeremy Heaton

  31. glad to know that….
    btw…maybe you’ll these….( everyone….maybe )
    http://ubuntuforums.org
    http://help.ubuntu.com/community
    http://psychocats.net/ubuntu

    regards;
    ~E~


Comments RSS TrackBack Identifier URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s